Error #3214 Issue


#1

After downloading Defender’s Quest on Steam yesterday, I played for approximately 1 hour and shut the game down. When I told the game to quit, it would stay open, active and useable (I could start a new game, for instance, even after hitting Quit). I ended up forcing the game to close through the Task Manager.

Today, I have tried to turn the game on and after the game loads it’s assets, it sends me to an error screen with the text:


An error has happened!

Error #3214
Context: State_TitleMenu.onWaitForIt() Main.LoadOptions
Message: Error #3214

Stack Trace: (blank, no text entered here)

null

Over the top of this is an embedded window, which appears to have the licence agreement in it, written in black text (therefore, unreadable, can only tell it’s there because of it’s appearance over the white writing previously stated) as well as blue paragraphs stating ‘What this means:’. Again, as I experienced the first time I played, the Quit button at the bottom of the screen does not exit the game and simply does not respond (though the program in Task Manager is identified as Running).

Before initially playing, I messed around with the graphics settings, making the game full screen and in a widescreen format. I did not, though, mess with any sort of coding or edit files, nor install any mods. I did not install the demo version first, only the full version.

Any assistance to get this sorted would be appreciated.
-Skorbrax


#2

Omg, moments later I thought to validate the file integrity through the Steam client. It found a faulty file and replaced it. It now works.

Should have done that beforehand. I’m an idiot. Problem solved.


#3

Bump, I had this issue happen to me as well

bought this game today played for 3 hours, wasnt allowed to quit game, so i forced quit on task manager.

Left, came back 2 hours later and game wouldnt load, same error displayed

found this post, fixed my problem thanks