Game suddenly requires Adobe AIR?


#1

Hi, I bought the game on GOG and it has ran fine without any issue until today when it suddenly started saying it needed Adobe AIR. I downloaded and installed it just to be sure but it still says I need it. Any help?


#2

You will always need AIR to run DQ, because it needs it. (Redundancy here. :stuck_out_tongue: )

But anyway, did you change any directory or anything? Did you do anything related to AIR or DQ (ANYTHING) between the first time you played and the time where the bug occurred? Maybe this can be dug more into if you spit out some moar info.

Thanks in advance.

PS: Please give the version of the game you are using and OS (I don’t really know if that matters, but it does).


#3

— Begin quote from "Shade"

Hi, I bought the game on GOG and it has ran fine without any issue until today when it suddenly started saying it needed Adobe AIR. I downloaded and installed it just to be sure but it still says I need it. Any help?

— End quote

Looks like something went wrong with the installation. While Adobe AIR was originally a dependency that had to be installed separately, it now comes as part of the DQ package - in the directory with DQ, there should be directory tree Adobe AIR directory/Versions/1.0 - and in there the Adobe AIR.dll itself and a Resources directory with more stuff.

I just tried the current GOG build and its Adobe AIR is 20.995.432 bytes, dated from 10th February this year. See if you can find yours - by what you’re saying it looks like it might have gotten deleted/corrupted.