[Linux] worked fine up to 1.0.50 version


#1

Hello guys, first post on this wonderful forum. :sunglasses:

Here is the deal. Ever since i purchased the game, i have been able to get the game running on a Lubuntu 12.10 desktop pc without any problems.

Now with the latest update available 1.0.64, the game freezes after all assets are loaded right before the title screen.
In other words, i get stuck with a black screen with a loading message.

So i tried re installing the game using the compressed tar file, instead of the .deb file but the same thing happens.

Then i managed to delete the config.xml file in the .appdata folder in order to reset all game settings back to default.

Now i am able to get to EULA screen but when i click the accept button, the game hangs again and the config.xml does not get recreated as it should.

As a side note: i have not changed video drivers (nvidia 304.51), they are the same since the first time i have installed the game.


#2

Same here, 1.0.64 from tarball.Even zapping the whole .appdata directory doesn’t help.


#3

Phew…glad i am not the only one! :slight_smile:

And to make matters worse i can’t rollback to version 1.0.50, because i trashed the .deb file :cry:

A curious thing, in the package manager (GDebi or Synaptic) the version listed is 1.0.66 not 1.0.64.

Probably a typo but who knows… :?


#4

Whoa! This is certainly problematic! Okay, I’m going to try to reproduce this on my end and see if I can find out what’s wrong. I’ll upload some fresh .deb and .tar.gz files as soon as I can - any of you who don’t have tester credentials yet, please PM me for them and we’ll get this sorted out.


#5

New builds are up on the test server, DEB and TAR.GZ, version 1.0.69 (or will be shortly, the upload is 56% complete as of this writing).

I’ve tested them both and they work fine on my Linux Mint box. Try these out and see if this fixes the problem. If so, I will be pushing this out over the update server ASAP, and updating the store page’s links. I’ll also manually send download links to anyone who has trouble.


#6

I have tested both DEB and TAR.GZ version 1.0.69 and the problem is fixed. :smiley:

i have also noticed that this version has achievements, which i think is awesome.

Thank you very much!


#7

I just ran into this, but on the Steam version. I guess I should have left my game open! Is there a timeframe for a new release on Steam?

Thanks.


#8

Well, I’d like to get another patch out before GDC, which is week after next. So, the Steam version is broken currently but the direct build is fine?

For anyone on steam having trouble on Linux:
-Which distro are you running?
-Which version number is showing for the game? (Title screen, lower right corner)

Also, if I can get any confirmation from linux users on Steam that can mention whether the build is NOT broken for them, that’d be great too.


#9

Out of curiosity, i decided to the test the Steam version as well.

The game loaded without any problems and the version listed is 1.0.66 as opposed to the stand alone DEB and TAR.GZ which is 1.0.64 and never worked. (at least for me and coyot)

I tested on the latest Steam Client Build: Feb 24, 2013 and the BETA Build Mar 13, 2013 running Lubuntu 12.10. (Quantal)


#10

Weird. If it’s only the direct build, I might just push that live today since that doesn’t take very long, and I won’t have to worry about the steam version.